trying to deploy a build to the apache snapshots repository on windows.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

trying to deploy a build to the apache snapshots repository on windows.

edelln
Hi,
 
I am trying to deploy a build to the apache snapshots repository on
windows and I am getting the following error - does anyone know why I am
getting the following error (scp is in my path). (do I need to add
something to my settings.xml file).
 
thanks, Edell.
 
 
[INFO] Skipping missing optional mojo:
org.apache.maven.plugins:maven-site-plugi
n:attach-descriptor
[INFO] [install:install]
[INFO] Installing C:\Yoko_rmi\trunk\pom.xml to
c:\.m2\repository\org\apache\yoko
\yoko\1.0-incubating-M1-SNAPSHOT\yoko-1.0-incubating-M1-SNAPSHOT.pom
[INFO] [maven-one-plugin:install-maven-one-repository {execution:
default}]
[INFO] Installing C:\Yoko_rmi\trunk\pom.xml to C:\Documents and
Settings\edelln\
.maven\repository\org.apache.yoko\poms\yoko-1.0-incubating-M1-SNAPSHOT.p
om
[INFO] [deploy:deploy]
[INFO] Retrieving previous build number from apache-snapshot-repository
[WARNING] repository metadata for: 'snapshot
org.apache.yoko:yoko:1.0-incubating
-M1-SNAPSHOT' could not be retrieved from repository:
apache-snapshot-repository
 due to an error: Exit code: 1 - pscp: unknown option "-o"
      try typing just "pscp" for help
 
[INFO] Repository 'apache-snapshot-repository' will be blacklisted
Uploading:
scpexe://people.apache.org/www/people.apache.org/repo/m2-snapshot-rep
ository/org/apache/yoko/yoko/1.0-incubating-M1-SNAPSHOT/yoko-1.0-incubat
ing-M1-2
0061011.134024-1.pom
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
 
The following is in the pom.xml
 
 <plugin>
              <artifactId>maven-one-plugin</artifactId>
              <executions>
                <execution>
                  <goals>
                    <goal>install-maven-one-repository</goal>
                    <goal>deploy-maven-one-repository</goal>
                  </goals>
                  <configuration>
 
<remoteRepositoryId>apache-snapshot-repository</remoteRepositoryId>
 
<remoteRepositoryUrl>scpexe://people.apache.org/www/people.apache.org/re
pository</remoteRepositoryUrl>
                  </configuration>
                </execution>
              </executions>
            </plugin>
            <plugin>
Reply | Threaded
Open this post in threaded view
|

Re: trying to deploy a build to the apache snapshots repository on windows.

Gwyn
It's using pscp, not scp, and pscp doesn't support the "-o" option.

/Gwyn

On 11/10/06, Nolan, Edell <[hidden email]> wrote:

> Hi,
>
> I am trying to deploy a build to the apache snapshots repository on
> windows and I am getting the following error - does anyone know why I am
> getting the following error (scp is in my path). (do I need to add
> something to my settings.xml file).
>
> thanks, Edell.
>
>
> [INFO] Skipping missing optional mojo:
> org.apache.maven.plugins:maven-site-plugi
> n:attach-descriptor
> [INFO] [install:install]
> [INFO] Installing C:\Yoko_rmi\trunk\pom.xml to
> c:\.m2\repository\org\apache\yoko
> \yoko\1.0-incubating-M1-SNAPSHOT\yoko-1.0-incubating-M1-SNAPSHOT.pom
> [INFO] [maven-one-plugin:install-maven-one-repository {execution:
> default}]
> [INFO] Installing C:\Yoko_rmi\trunk\pom.xml to C:\Documents and
> Settings\edelln\
> .maven\repository\org.apache.yoko\poms\yoko-1.0-incubating-M1-SNAPSHOT.p
> om
> [INFO] [deploy:deploy]
> [INFO] Retrieving previous build number from apache-snapshot-repository
> [WARNING] repository metadata for: 'snapshot
> org.apache.yoko:yoko:1.0-incubating
> -M1-SNAPSHOT' could not be retrieved from repository:
> apache-snapshot-repository
>  due to an error: Exit code: 1 - pscp: unknown option "-o"
>       try typing just "pscp" for help
>
> [INFO] Repository 'apache-snapshot-repository' will be blacklisted
> Uploading:
> scpexe://people.apache.org/www/people.apache.org/repo/m2-snapshot-rep
> ository/org/apache/yoko/yoko/1.0-incubating-M1-SNAPSHOT/yoko-1.0-incubat
> ing-M1-2
> 0061011.134024-1.pom
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
>
> The following is in the pom.xml
>
>  <plugin>
>               <artifactId>maven-one-plugin</artifactId>
>               <executions>
>                 <execution>
>                   <goals>
>                     <goal>install-maven-one-repository</goal>
>                     <goal>deploy-maven-one-repository</goal>
>                   </goals>
>                   <configuration>
>
> <remoteRepositoryId>apache-snapshot-repository</remoteRepositoryId>
>
> <remoteRepositoryUrl>scpexe://people.apache.org/www/people.apache.org/re
> pository</remoteRepositoryUrl>
>                   </configuration>
>                 </execution>
>               </executions>
>             </plugin>
>             <plugin>
>
>


--
Download Wicket 1.2.2 now! - http://wicketframework.org

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]